What are the Super Cutter system requirements?

The Super Cutter software has been developed and tested on a variety of machines.

Must have:
– Windows PC (Windows 10 preferred)
– Google Chrome Browser (Up to date preffered)
– Up to date Super Cutter desktop app

Plotters:
The Super Cutter software is designed to work with all manner of plotters using HPGL language. While we will never be able to test EVERY plotter on the market, our team has done extensive testing on the following plotters, that are globally available, and are adding more daily.

Full Support (including checking material width, etc)

– GCC (Expert II, Puma IV, Jaguar V, others)

– Roland (GS-24, Camm 1)

– Graphtec (CE7000, FC9000)

Partial Support (Can cut successfully, but some features such as automatic material width check will not)

– Roland (Camm 1)
– Graphtec (FC8600)

– US Cutter (MH721-MK2)

Other plotters may work with the system. There is built-in testing functionality, and our team is here to support.

To test your plotter, please submit your account request. Once your account is approved, you will have access to the control panel. You will be able to run the ‘test cut’ function, which is a small cut that you can complete on any vinyl. This mimics the entire cut process, so if your plotter is working, you are good to go!

We want to get you up and running, so we do have processes in place to test and resolve issues with other existing plotters. If you are having any troubles, please reach out to your rep or our customer service team!